Temporary Fix for 'Keyboard Not Working' Error in Ubuntu 9.04

This article was written by Blair Mathis. Blair works with where she is responsible for all Linux/Ubuntu related articles. At you can find all the information you need on the best gaming laptops and go through the latest Acer laptop reviews.

As always, the latest version of Ubuntu, 9.04, was released on time. It offers faster boot time, ext4 support, and many other minor updates and tweaks that makes the system better. Unfortunately, in addition to the updates, there’s a fairly serious (aka, annoying) bug in Ubuntu 9.04 that causes a certain combination of buttons–most commonly, the Fn+UP/DOWN and volume buttons—to render the keyboard completely dead, as well as the system menus and the right-click menu that appears when using the mouse. This bug appears in many different ways, as evidenced by the varying bug reports, but it always has the same symptoms.

While there’s no reported cause for the bug—only acknowledgement that it exists—users are forced to hard reset their system to correct the problem; restarting the X server is impossible, due to the lack of keyboard, and the system menus disappear, preventing a simple log in/log out fix.

Because a hard rest is not a viable option when using the system for work (or at all, for that matter), it would seem those plagued with this bug are forced to install 8.04 or temporarily abandon their system for a different one. Luckily, if you’re willing to stick it out for awhile until the coveted bug fix is released, there is a simple solution to unlocking the keyboard that does not involve a hard reset:


Or any other key F1-F12. The screen will temporarily turn black, and a system beep might occur, and then the keyboard and menus will continue working as normal. The buttons that trigger the bug will continue to act poorly, however.

If you’re experiencing their bug with your system, be sure to report it so that a solution can be found as quickly as possible.

Archived Comments

Ehud Kaldor

After having ran into this bug a few times (and wanted to Kill someone during), i searched and found this solution (i don’t remember where, so i don’t post a link. credits to whoever posted first):
build a customer application launcher on taskbar, in which the command is setxkbmap
worked for me every time so far…


I must say i quite don’t get how you’re supposed not being able to restart X due to a lack of keyboard, while the proposed way to unlock X is … a keyboard shortcut…

I guess what makes restarting X impossible is the fact that Ubuntu disabled the CTRL-ALT-BACKSPACE shortcut in Jaunty…which can be re-enabled by adding the following to your xorg.conf (and restarting X, of course):

Section “ServerFlags”
Option “DontZap” “false”

brian t

I actually saw this more in 8.10 than 9.04 on eee PC 1000 - just once since I upgraded a month ago. When that happened I could still use e.g. Firefox with the mouse only, and close it and other applications properly. As noted, you can always switch to a terminal using e.g. Ctrl-Alt-F1, but that wasn’t a fix, since the X session on Ctrl-Alt-F7 was still without keyboard.

I could restart X from another terminal using “sudo /etc/init.d/gdm restart” and log in again.I wonder whether Ctrl-Alt-Backspace would restart the session? I’ve only just enabled that by setting Option DontZap “False” in xorg.conf, so I’ll try it if this happens again.


I concur. The bug does exist (with the FN+Up/down arrows -> pgup/down) in 8.10. It just happened actually!

My non-optimal solution had been to restart the X server with ctl-alt-backspace.This of course can be fatal, depending what you’re working with. It is, however, much much better than hard reset. I suggest people reactivate a shortcut for restarting the X or learning how to do it via the terminal (after ctl-alt-f1).

I will try Ehud Kaldor’s solution next time though and I hope it will work!



nope, just did and the setxkbmap solution above didn’t help….


I’m not currently having the keyboard problem and I am amazed that this is usable when the keyboard isn’t working. I guess that means that the keyboard doesn’t appear to work.

At any rate, when I do this I am dumped into a TTY3 and asked to log in. If your command line skills are left wanting then you’ll need some help.

shutdown -r will do a safe reboot (safer than holding down the power button)

You could try removing /tmp/.XO-lock and then running startx, but that could be problematic and I don’t know if it will actually work.

Note that tty7 is where you normally are when logged in, so an Alt-7 will get you back to your screen.


Fascinating. I’ve had weird lockups where the mouse moves but the keyboard is completely unresponsive. Hmmm. After a hard reset, there’s filesystem corruption and I have to run fsck from a LiveCD before the partition becomes available again. This is on 64-bit jaunty. There’s a thread about that here, and a bug report here. Since the initial symptom is similar, at least for me, I wonder if this is all the same general issue. ??


Is this article correct? When I press CTRL + ALT + F3 I end up having a command line only.

Daniel PA

Not precisely incorrect, but incomplete. After ctrl+alt+Fsomething you go back to grapchics mode by pressing now ctrl+alt+F7. So the first time you shouldn’t use ctrl+alt+F7 :) (F1 to F6 are text terminals). Still, the fix may not always work.


I was out of town for a while, but I finally had a chance to try ctrl-alt-f3 to get out of the type of lockups I’ve had. In my case it doesn’t work. The key combination just leads to a black flashing screen, and the system still needs a hard reset, and there’s still the filesystem corruption that needs to be fixed with fsck. So it seems like this is a separate issue.

I wish they’d get it sorted out. I love jaunty when it works!


(Mine was indeed different. It’s Bug 346691 and the workaround is to upgrade from the kernel to 2.6.29.)


This look interesting,so far.
If there’s anyone else here, let me know.
Oh, and yes I’m a real person LOL.



same problem here: keyboard; mouse ; menus; right clicks all not working
sometimes pressing the shift button (like now) lets me write or rightclick other times everything is just without response
this is getting very annoying… does anybody know if there are other temporary solutions? or some thread? i dont even have a clue on what to search for


same problem here: keyboard; mouse ; menus; right clicks all not working
sometimes pressing the shift button (like now) lets me write or rightclick other times everything is just without response
this is getting very annoying… does anybody know if there are other temporary solutions? or some thread? i dont even have a clue on what to search for


found a temporary solution that lets me use a usb keyboard but from then on the laptop keyboard is completely dead until next reboot when the problem comes back on randomly

sudo sh -c ‘echo -n “i8042” > /sys/bus/platform/drivers/i8042/unbind’

please it would be nice to have some feedback if anyone still reaDS this..


Your welcome everyone,
My computer worked slowly, too much mistakes and buggs. Please, help me to fix buggs on my computer.
I used Windows XP.
With best regards,


This fellow my be of interest:


Solution proposed on Post #103 in works for my HP Pavilion DV6000 as well.


I’ve Coach Signature Zoe, I really like this particular handbag!! It was last one with one of these shades in the store. I haven’t found it at another Coach shop often. I asked the clerks relating to this handbag and so they declared that this specific purse is very hot that when they get it, it sells out that week!! Nuts! Coach Zoe Bag is made with Coach Signature material that is treated to be stain and waterproof. Trimmed using platinum natural leather and also metallic equipment. Either side possesses pretty silver buckles, like the Carly. Neck band provides dogleash end as well as the internal is lined in glowing blue silky textile with several pockets.


what drivel if your keybd doesn’t work how are you supposed to do ANYThIng? hard resets don’t do anything, but bring back same mindless screen. install disk sows nothing. it’s a motherboard problem.

Jabba Laci

I had a similar problem, some buttons stopped working correctly on the right side of my laptop keyboard. The problem was quite silly: the Num Lock button was pressed accidentally :) So if your keyboard behaves strangely, check it first.



Respond via email