Fix libpango Dependency Errors

I’ve been having errors like this one when trying to update or install some packages on Ubuntu 7.10:

Depends: libpango1.0-0 (>=1.18.3) but 1.18.2-0ubuntu1 is to be installed

Pango is the text layout and rendering library that GTK uses. The version that’s missing is in the Ubuntu 7.10 gutsy-updates (backports) repository. However, even with this repository enabled apt wouldn’t install it.

Here’s the solution I found:

  1. Download the package from the libpango1.0-common page and install it. This is needed prior to installing libpango.
  2. Download the package from the libpango1.0-0 page and install it.

After those two packages were installed, everything that was depending on libpango installed successfully.

Archived Comments


Muchas Gracias, la solución funciono perfectamente…


thank you!!!


every time I try the first one I keep getting an error on that screen ‘two or more packages specified (libpango1.0-common gutsy-updates)’

The second one just takes me to a blank screen that says ‘done’ in my progress bar …

Perhaps I’m having a different problem, the last line just says
E: libpango1.0-dev: dependency problems - leaving unconfigured
Or perhaps it’s because I’m using a more recent version of ubuntu ?

Respond via email