I’ve been having errors like this one when trying to update or install some packages on Ubuntu 7.10:
Depends: libpango1.0-0 (>=1.18.3) but 1.18.2-0ubuntu1 is to be installed
Pango is the text layout and rendering library that GTK uses. The version that’s missing is in the Ubuntu 7.10 gutsy-updates (backports) repository. However, even with this repository enabled apt wouldn’t install it.
Here’s the solution I found:
- Download the package from the libpango1.0-common page and install it. This is needed prior to installing libpango.
- Download the package from the libpango1.0-0 page and install it.
After those two packages were installed, everything that was depending on libpango installed successfully.